Supported Components

This documents the version support on various java/scala JDK and frameworks

JREs

  • Oracle/Sun, OpenJDK: 6 - 13
  • IBM: 6 - 8

Application/HTTP Servers

  • Glassfish: 2.x - 5.x
  • Wildfly: 8.x - 18.x
  • JBoss: 5.x - 7.x
  • Jetty: 6.x - 9.x
  • Resin: 3.x - 4.0.x
  • Tomcat: 5.x - 9.x
  • Netty: 3.x - 4.x
  • Undertow: 1.x - 2.x
  • gRPC server: 1.x
  • Websphere/Websphere Liberty Profile: 7.0+
  • WebLogic 11g - 12c
  • Akka HTTP server: 10.x
  • Glassfish Grizzly HTTP server: 2.x

Web Frameworks

  • Spring MVC: 3.0 - 5.x
  • Spring Boot: 2.x
  • Spring Web Flow: 1.x - 2.x
  • Apache Struts: 2.x
  • Apache MyFaces JSF: 1.2 - 2.2.8
  • Play: 1.1 - 2.8
  • Grails: 1.0 - 1.3, 1.4 - 2.3.6
  • JBoss EJB: 4.x - 8.x
  • Spray
  • Spray-can: 1.1.x - 1.3.x

Java HTTP Clients

  • Apache HttpClient: 3.x - 4.x
  • Apache AsyncHttpClient: 4.x
  • gRPC client: 1.x
  • Java HTTP client: 11+
  • OkHttp client: 3.x - 4.x
  • Apache CXF: 2.2.1 - CXF 3.3.1
  • Apache Axis2: 1.x
  • Sun Jersey: 1.x
  • Glassfish Jersey JAX-RS 2.0: 2.x
  • JBoss RESTEasy: 2.x - 3.x
  • JDK javax.xml.soap: 1.6 - 1.7
  • Restlet: 2.x - 3.x
  • Spring RestTemplate: 3.x - 5.x
  • Play WS: 2.2 - 2.8
  • JDK HttpURLConnection: 1.5+
  • Spray HTTP client: 1.x
  • Akka HTTP client: 10.x
  • Jetty HTTP client: 9.x

Databases

  • Cassandra CQL via Datastax 1.0.0 - 2.0.x
  • Cloudera HBase 0.92.x - 1.1.1
  • MongoDB 2.x - 3.x
  • Oracle JDBC Thin 11.x, 12.x
  • Redis Jedis 1.3.0 - 2.6.1
  • Redis Redisson 1.0.1 - 1.3.0
  • IBM DB2
  • MySQL
  • Oracle JDBC OCI
  • PostgreSQL
  • Apache Derby
  • Apache DBCP
  • c3p0
  • HSQLDB
  • Microsoft SQL
  • Hikari
  • MariaDB
  • IBM AS400
  • Sun DB Proxy
  • DataNucleus RDBMS

Other components

  • Apache Solr: 1.3.0 - 8.x
  • Ehcache: 1.x - 2.x
  • Spymemcached: 2.4.x - 2.12.x
  • xmemcached: 1.x - 2.x
  • Akka-actor: 2.1 - 2.4
  • Spray-can HTTP server: 1.1.x - 1.3.x
  • Java ThreadPoolExecutor: 1.5+
  • Java ForkJoinPool: 1.7+
  • Kotlin Coroutines: 1.0.0 - 1.2.0
  • RabbitMQ: 2.x - 3.x
  • Log4j2: 2.x
  • Log4j: 1.2.x
  • Logback: 0.9.8 - 1.2.3